?

Log in

No account? Create an account

CamelCase -> Camel case
vladfrost
// Разбивает строку из нескольких объединенных слов в строку с отдельными словами.
// Признаком начала нового слова считается символ в верхнем регистре.
//
// Параметры:
// Строка - Строка - текст с разделителями;
//
// Возвращаемое значение:
// Строка - строка, разделенная по словам.
//
// Примеры:
// РазложитьСтрокуПоСловам("ОдинДваТри") - возвратит строку "Один два три".
// РазложитьСтрокуПоСловам("одиндватри") - возвратит строку "одиндватри".
//
Функция РазложитьСтрокуПоСловам(Знач Строка)

МассивСлов = Новый Массив;

ПозицииСлов = Новый Массив;
Для ПозицияСимвола = 1 По СтрДлина(Строка) Цикл
ТекСимвол = Сред(Строка, ПозицияСимвола, 1);
Если ТекСимвол = ВРег(ТекСимвол) Тогда
ПозицииСлов.Добавить(ПозицияСимвола);
КонецЕсли;
КонецЦикла;

Если ПозицииСлов.Количество() > 0 Тогда
ПредыдущаяПозиция = 0;
Для Каждого Позиция Из ПозицииСлов Цикл
Если ПредыдущаяПозиция > 0 Тогда
Подстрока = Сред(Строка, ПредыдущаяПозиция, Позиция - ПредыдущаяПозиция);
Если Не ПустаяСтрока(Подстрока) Тогда
МассивСлов.Добавить(СокрЛП(Подстрока));
КонецЕсли;
КонецЕсли;
ПредыдущаяПозиция = Позиция;
КонецЦикла;

Подстрока = Сред(Строка, Позиция);
Если Не ПустаяСтрока(Подстрока) Тогда
МассивСлов.Добавить(СокрЛП(Подстрока));
КонецЕсли;
КонецЕсли;

Для Индекс = 1 По МассивСлов.ВГраница() Цикл
МассивСлов[Индекс] = НРег(МассивСлов[Индекс]);
КонецЦикла;

Если МассивСлов.Количество() <> 0 Тогда
Результат = СтрСоединить(МассивСлов, " ");
Иначе
Результат = Строка;
КонецЕсли;

Возврат Результат;

КонецФункции
Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там.
Tags:

Хозяйке на заметку
vladfrost

Максимальная длина строки, для которой можно включить индексирование в файловой базе 1С: 634 символа

Если попытаться поставить большую длину, при обновлении информационной базы получим сообщение

В процессе обновления информационной базы произошла критическая ошибка
по причине:
Ошибка СУБД:
Длина ключа индекса превышает максимально допустимую

Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там.
Tags:

[reposted post]"Алко-Контроль" в действии. Раменское
artushin
reposted by vladfrost
Продолжение деятельности независимо возникшей и действующей после озвучивания нашей инициативы раменской группы, занятой выявление и изобличением торговых точек, продающих алкоголь несовершеннолетним и в запрещенное законом время.

Сообщение о том, что в магазинчике ИП Цветынина по адресу город Раменское, улица Железнодорожная, дом 47 (это рядом с железнодорожной остановкой "47 км") поступило на телефон горячей линии "Алко-Контроля" +7 (925) 002-13-60. Местные раменские активисты ознакомились на месте с ситуацией, а затем в 21:43 (время подтверждается телефонным звонком в сервис 100 на отметке 2:09 видео) произвели закупку, пригласив затем полицию. Впрочем, смотрите сами все на видео:


читать далееCollapse )

Присоединяйтесь к нашей инициативе! Или хотя бы помогайте распространять данный пост в соцсетях. Может быть кто-то из Ваших читателей или читателей Ваших читателей прочтет репост и займется этим полезным делом, повторюсь, лишенным какого-либо политического окраса. Защита подростков от алкоголя - дело нужное и важное вне разницы чьих-либо политических принадлежностей и симпатий.

Кстати, создали группу "Алко-Контроля" в сети ВКонтате, подписывайтесь.

Секретное оружие, благодаря которому мы победим
vladfrost

Есть ли у нас секретный прием — «серебряная пуля» на последние дни избирательной кампании? Конечно, есть, и мы собираемся повесить его на ваш холодильник.

Любой опрос, хоть проплаченный кремлевский, хоть объективный и независимый, показывает, что в Москве есть несколько миллионов человек, отлично понимающих, что происходит, и желающих перемен. Эти люди готовы проголосовать за Алексея Навального. Потому что они хотят реальной, а не «понарошку» борьбы с коррупцией. Они хотят независимых судов. Они хотят платить за ЖКХ столько, сколько это стоит, а не столько, сколько насчитали монополисты и чиновники за сигарой с виски. Они понимают, что город с таким огромным бюджетом должен дать жителям несоизмеримо более высокое качество жизни, чем имеют москвичи.

Любой опрос показывает также, что в Москве есть миллионы людей, которые голосуют за власть просто потому, что она власть. Люди просто голосуют за Собянина (за Лужкова, за Ельцина, за Путина) потому, что он «начальство». Есть миллионы горожан, которые верят в то, что говорят по телевизору. Они обычные хорошие люди, просто они привыкли верить телевизору.

Выборы выиграет тот, кто приведет на избирательные участки больше своих сторонников. Да, телевидение, работающее против нас, бомбит по площадям. Каждый заказной репортаж видят полмиллиона человек. Зато у нас мотивация в миллион раз выше. Зато мы знаем, что мы правы. Зато мы точно знаем, что трехминутный агитационный разговор с любой жертвой зомбоящика превращает ее (жертву) в нормального человека, который проголосует в нашу пользу.

Секретное оружие (оно же «Серебряная пуля», оно же «Оружие возмездия», оно же «Политический плазмаган», оно же «Остро заточенный сюрикен москвичей») может быть только одно:

Сто тысяч человек, которые повесят на свой холодильник этот чек-лист и добросовестно выполнят его. Это очень легко. Это может сделать каждый. Это должен сделать каждый. Тогда мы приведем на избирательные участки больше своих сторонников и выиграем. Нам нужно привести полтора миллиона человек. Это не просто возможно, это совсем реально. Ведь их нужно мобилизовать из тех реально существующих трех миллионов избирателей, готовых голосовать за перемены. Просто им лень идти на участок.

Если вы их лично попросите, они точно придут. Гарантированно. Все зависит от вас.

Вот вы сейчас подумали: «От меня надо только 5—10 человек в этих полутора миллионах. Незначительная цифра, которая ничего не изменит. Значит, и мучиться не буду. Сам схожу и проголосую, этого достаточно. ЖЖ Навального читают 250 тысяч человек в сутки, они все сделают».

Это и была самая ужасная мысль. В этот момент все и рухнуло. В этот момент ничего у нас не получилось. Это не делегируется. Это не перепоручается. Это ничем не заменяется. Каждый делает дело, и тогда мы выигрываем. Или вы думаете: «От меня ничего не зависит» и выигрывает «Единая Россия». Жаба_На_Трубе довольно щурится, перебирает лапками и думает: «Сосунки, у них был шанс, но им снова было лень».

Этот чек-лист надо скачать отсюда. Повесить во все свои соцсети. Распечатать. Повесить на холодильник. И добросовестно выполнить каждый пункт. Это программа-минимум для каждого, мы уверены, что 32 тысячи человек, зарегистрированные на «Навальный в каждый дом», сделают гораздо больше. И мы дадим им (нам) более сложные поручения. Большинство из них (нас) эти поручения выполнят. Но въехать в светлое будущее только на усилиях героев не получится. Нужен вклад каждого.

Чтобы сделать все, здесь предусмотренное, вам надо будет потратить совсем мало времени. Вы гарантированно тратите больше каждую неделю просто на просмотр картинок с котиками и собачками в Интернете. Инвестируйте это время в общую победу. Тогда мы ее добьемся.

Ваш холодильник ждет.

Каждый раз, открывая его и видя (или не видя) на нем наше секретное оружие, вы будете точно знать, действительно ли вы хотите перемен или готовы и дальше покорно кормить Жабу_На_Трубе.

Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там.

Предвыборная агитация Собянина
vladfrost

Вчера и сегодня наблюдал за предвыборной агитацией Собянина. В доме, в котором я живу, есть собес. Вчера вечером к собесу подъехала газель и из неё стали выгружать в большом количестве агитматериалы: конфеты, шоколадки, печеньки и прочие кондитерские изделия. Сегодня все эти явства разложили по пакетикам и стали разносить, как я предполагаю, по окрестным жителям. Что это такое, как не подкуп избирателей за счет городского бюджета?

Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там.

Спонсор Навального
vladfrost
В интернетах спрашивают, кто спонсирует Навального. Вот, признаюсь, это я его спонсирую. Очередной транш ушёл в пятницу.

Навальный

Сегодня ещё отправлю.

Так победим!

Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там

А давайте я...
vladfrost
Вот это да! Не ожидал от tarlith_history

Оригинал взят у tarlith_history в А давайте я...
...скажу ВНЕЗАПНОЕ.
Приходите 8-го и голосуйте за Навального.
Понятно, что никакой победы Навальному не светит - просто объективно, но щелкнуть ССС по носу, вывести во второй тур и, таким образом, снизить его когалымское влияние - это очень даже реально.
К тому моменту, как вы дочитали до этих слов, первый шок должен был пройти.
Поэтому я в двух словах поясню, почему Навальный, а не кто-то другой. Во-первых, он националист (хоть и непоследовательный) и понимает, что ДефолтСити пора зачищать. Во-вторых, он типичный аппаратчик в хорошем смысле этого слова - меняет людей, корректирует мнение в зависимости от повестки. Это не плохо и не ужасно, это условие существования и выживания в аппаратном мире. В-третьих, да, он немножко Ельцин и немножко Путин, то есть вполне себе современный консервативный политик. Иными словами, если он попадет во власть, он будет играть по правилам, а смешных волосатиков и гнилорыбовых отправит туда, где им место.
Собственно, почему Собянин отслюнявил ему мундепов для прохождения фильтра? Да потому что он системный и консервативный по факту, а всякие вопли и эпатажные высказывания - это для публики, этим, знаете ли, и ВВП, ув., балуется.
Как-то так, да.

З.Ы. Я тут в адрес Навального услышал забавный термин "тюнингованый нашист". Первая реакция - "вы так говорите, как будто в этом есть что-то плохое". Знаете, я с лоялистскими молодежками поработал изрядно - и многие люди, прошедшую эту школу, работают со мной сейчас на кампаниях разных уровней. Понятно, что буратин хватало - ну а где их нет. Но в конечном итоге это - очень качественная школа, так что "тюнингованый нашист" это скорее комплимент.


Как пилят на детских площадках
vladfrost
Оригинал взят у naganoff в Территория крепких хозяйственников
Продолжаем тему тендеров, крепких хозяйственников и эффективных менеджеров в Москве, собирающихся управлять городом ещё один срок.

Вот фотоотчёт активистов московского Народного Альянса по тендеру № 0373200039712000008 - выполнение работ по устройству детской игровой площадки по адресу Бакунинская ул., д.17/28. Тендер выполняла компания ООО «Континент» из города Саратов (город Саратов , ул. 50 лет Октября, д. 118 А, 716 ). А инженерная служба оплатила тендер в полном объеме в 1,8 млн. рублей. Работы выполнили осенью 2012 года.

Вот сама детская игровая площадка (100 кв. м):

IMG_1001
Есть еще и спортивная площадка (100 кв. м.):

Read more...Collapse )

Follow @naganoff_ru



Map


Позарез нужна ваша помощь...
vladfrost
Оригинал взят у dgudkov в Позарез нужна ваша помощь...
...чтобы выиграть битву под Москвой!


Отсюда

Друзья!

Геннадий Гудков, наконец, официально зарегистрирован кандидатом в губернаторы Московской области. Теперь уже всем совершенно ясно, что борьба за пост главы Подмосковья развернется между едросом Воробьевым и кандидатом от оппозиции Гудковым. И нам очень нужна ваша помощь, чтобы достучаться до избирателей и добиться второго тура выборов, в котором власть почти всегда проигрывает!

В этой борьбе нам противостоит огромная орда чиновников, у них — неограниченные финансовые ресурсы, колоссальные штабы, прикормленные СМИ, полиция и прокуратура. А нас — рать :) — миллионы граждан, понимающих, что стране нужны перемены и что дальше так жить нельзя.

Мы можем победить только с помощью народной поддержки, только вместе с Вами, и у нас для этого есть очень хорошие шансы. Все, что нам нужно, — это хорошая, активная, наступательная агитационная кампания.

Задача, конечно, не из легких. Ведь борьба за Подмосковье проходит в тени выборов мэра Москвы.
Независимые журналисты федеральных изданий освещают кампанию Алексея Навального, что понятно. Зомбоящик показывает только С.Собянина и А.Воробьева. В этих условиях рассчитывать на федеральные СМИ не приходится. Ну, если, конечно, СК не попробует, например, посадить Геннадия Гудкова в тюрьму.

Областные медиа слишком зависимы от местных властей, а интернет на выборах губернатора Подмосковья, увы, большой роли не играет. Поэтому в Московской области будем использовать традиционные методы агитации – личные встречи, распространение газет, листовок, плакатов и т.д.

Встречи, вокзалы

Как известно, больше миллиона жителей Московской области работают в Москве. Поэтому попробуем поагитировать прямо на вокзалах, там, откуда отправляются пригородные электрички. В часы-пик там всегда много людей. Каждый день — новый вокзал, общение с жителями области, распространение наших агитматериалов. Оттуда наш кандидат на электричках будет выезжать на встречи с избирателями в разных городах области, а также с инициативными группами, активистами, волонтерами. "7 дней — 7 вокзалов — 1 000 000 рукопожатий" — так за месяц можно сагитировать очень многих жителей Подмосковья.

В ближайшее время собираемся устроить встречу Геннадия Гудкова с инициативными группами городов и районов области. Ее мы будем организовывать вместе с известным журналистом и блоггером oleg_kozyrev. Желающие принять в ней участие, пишите на gudkovd@ya.ru!


Если хотите помочь с организацией встречи с избирателями в своём городе/районе, то звоните нам на 84957950822.

Финансирование, агитация

К сожалению, никто кроме нашего штаба реальную кампанию вести не будет. Парламентские партии, по сути, уклонились от борьбы, выдвинув технических кандидатов в губернаторы. Некоторые из них даже избрали объектом критики не временного губернатора Воробьева, а почему-то Геннадия Гудкова. В области пока "сонное царство", и это плохо, потому что работает на низкую явку, выгодную "Единой России". А при низкой явке, как вы понимаете, добиться второго тура сложнее.

Пока расклад такой: у Воробьева есть админресурс, зомбоящик и "Единая Россия". У нас — большое желание изменить ситуацию в Подмосковье к лучшему и, главное, ваша поддержка! В стране много честных людей, которые хотят изменить жизнь вокруг себя и понимают, что успех независимого кандидата на выборах в любом крупном регионе станет общей победой.

Для наступательной агитационной кампании нам необходимы:

- тиражи газет,
- билборды,
- плакаты,
- баннеры,
- транспорт,
- социология и т.д.
- юристы и другие сотрудники штаба

На все это нужны деньги, которые можете дать только вы!

Для успешной кампании необходимо печатать газеты и листовки, арендовать автомашины, платить за политическую рекламу и СМИ, изготавливать стенды, закупать билборды, майки, наклейки и многое другое.

Мы долго думали — собирать деньги в интернете или нет. Ведь Подмосковье — не Москва, фандрайзингом здесь по-серьезному никто не занимался. Но выхода у нас нет, потому что без денег революцию не сделаешь! Мы, конечно, — не революционеры, но и без средств победить почти невозможно.

Если не будет агитации, то многие жители Московской области и дальше будут думать, что лучше «Единой России», Воробьева и Путина никого нет и быть не может.

Давайте постараемся их переубедить! Давайте вместе добьемся второго тура выборов! У Геннадия Гудкова есть реальные сторонники в Подмосковье, где он несколько раз побеждал всех конкурентов по одномандатному округу и набирал почти половину голосов всех избирателей; где он родился и вырос, где уже 12 лет работает его команда. Нужно всего лишь мобилизовать всех наших сторонников и убедить сомневающихся проголосовать именно за Геннадия Гудкова.

И тогда будет так:


Фото1

Но для победы нам очень нужна ваша поддержка!

Важно помнить, что настоящую независимость политику можете дать только вы. Настоящая независимость — это когда тысячи простых граждан "скидываются" на поддержку своего кандидата, направляют средства в избирательный фонд. Такая поддержка дорогого стоит.

Если вы действительно поддерживаете Геннадия Гудкова, поддержите его финансово! Для этого НЕОБЯЗАТЕЛЬНО жить в Подмосковье: КАЖДЫЙ гражданин страны имеет право нам помочь. Все ваши средства будут зачислены на избирательный счет, с которого они могут быть потрачены ТОЛЬКО на избирательную кампанию.

Совсем недавно все кандидаты сдали так называемый 1-й финансовый отчет. На счет Воробьева поступило 212 млн. руб., на счет Гудкова — около 1 млн.

Поправим ситуацию, и
вместе у нас все получится!


Как перевести деньги на счет ГудковаCollapse )

P.S.: Уже более 150 волонтеров записались в наш штаб, но мы ждем еще. Нам нужна Ваша ежедневная поддержка. Агитируйте друзей, знакомых, соседей, помогайте распространять наши агитматериалы, распространяйте их в том числе на всевозможных форумах и в социальных сетях. Записывайтесь волонтером в наш штаб по тел 8(495)-795-08-22 или 8(925)-123-32-41 (Дмитрий Анисимов). Пишите на teamgudkov@gmail.com.

Прошу также распространить этот пост везде, где только можно. Обязательно пишите в своих соцсетях, что вы перечислили деньги на счет Гудкова. Не забудьте сообщить об этом мне в твиттер – ретвит и благодарность гарантирую!)


Скачивайте наши агитматериалыCollapse )

Всем заранее большое спасибо за поддержку!



Отменить закон о произвольных блокировках интернетов
vladfrost
Суём голым за отмену закона о произвольных блокировках. Иначе завтра могут заблокировать и твой вконтактег.

Запись опубликована в Блок-тормозе Фроста. Вы можете комментировать здесь или там